Not too long after WordPress 2.5 was released, update 2.5.1 followed soon thereafter containing significant updates for the lots of new things in the 2.5 series. But even just after 2.5.1, some problems were exposed, notably the one that requires you manually resetting your passwords because the password recovery links wouldn’t work as designed. The patched files can be downloaded from the user who discovered the problem, and used on your site, replacing the 2.5.1 versions.

Additionally, there is also a fix to allow users to revert to the old image uploader if a browser is not flash enabled. This can be very helpful especially if you update your blog using different PCs with various configurations. The fix is now available as a plugin.